Project

General

Profile

Bug #991

Problem with paypal payments

Added by Lorenzo Monti about 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
10/26/2013
Due date:
% Done:

100%

Invoice time (hours):

Description

My site is live, magento 1.7.0.2, but paypal pro payments have lots of troubles.
Little orders can pass payments.
Big orders, instead, register a timeout when connecting to Paypal.
On the network, every kind of checkup has been done, IPs whitelisted etc...
The only error I still need to cleanup is this, I found in the system log:
2013-10-26T21:13:11+00:00 ERR (3): Strict Notice: Declaration of ET_CurrencyManager_Helper_Tax::getPrice() should be compatible with that of Mage_Tax_Helper_Data::getPrice() in /home/alchemia/public_html/app/code/community/ET/CurrencyManager/Helper/Tax.php on line 21
2013-10-26T21:13:13+00:00 ERR (3): Strict Notice: Declaration of ET_CurrencyManager_Model_Store::roundPrice() should be compatible with that of Mage_Core_Model_Store::roundPrice() in /home/alchemia/public_html/app/code/community/ET/CurrencyManager/Model/Store.php on line 21
2013-10-26T21:13:13+00:00 ERR (3): Strict Notice: Declaration of ET_CurrencyManager_Model_Store::roundPrice() should be compatible with that of Mage_Core_Model_Store::roundPrice() in /home/alchemia/public_html/app/code/community/ET/CurrencyManager/Model/Store.php on line 21

Store.php View (902 Bytes) Lorenzo Monti, 10/26/2013 11:16 PM

Tax.php View (1.67 KB) Lorenzo Monti, 10/26/2013 11:16 PM

Data.php View - from /app/code/core/Mage/Tax/Helper (28 KB) Lorenzo Monti, 10/29/2013 08:03 AM

Store.php View - from /app/code/core/Mage/Core/Model (34.2 KB) Lorenzo Monti, 10/29/2013 08:03 AM

History

#1 Updated by Jurij Nikolajev almost 8 years ago

  • Status changed from New to In Progress
  • Assignee set to Jurij Nikolajev
  • Target version set to ver. unsorted tasks

I cannot reproduce these errors on our sites and function declarations does not differ from core functions (from fresh installation).
Please provide your files Mage_Tax_Helper_Data and Mage_Core_Model_Store so that we could check if they were modified.

P.S. Do troubles with paypal payments disappear if you disable Currency Manager extension (in /app/etc/model/*)?

#2 Updated by Lorenzo Monti almost 8 years ago

If I remove the xml in /app/etc/model, the error is the same.
Attaching the files you asked.

#3 Updated by Jurij Nikolajev almost 8 years ago

Lorenzo Monti wrote:

If I remove the xml in /app/etc/model, the error is the same.

If our extension is disabled and you still get issue with payments - our extension is not the source of problem.

#4 Updated by Jurij Nikolajev almost 8 years ago

I see no difference in functions declaration.
I can help you to resolve this errors in log file only if you provide access to your site. DO NOT POST any access data here. Send it to

If you need this kind of help, please provide us:
1. link to your site
2. link to admin panel
3. login/password to admin panel
4. ftp or sftp access (link, login, password)
5. steps to reproduce error (if known)

#5 Updated by Jurij Nikolajev almost 8 years ago

  • Status changed from In Progress to 3
  • % Done changed from 0 to 100

Got access data on dev server...

You have modified core files on your website. Those files are placed in
/app/code/local/Mage

Since our extension rewrites the same core function, you can
1. delete those files
2. change our extension to rewrite your new functions

#6 Updated by Jurij Nikolajev almost 8 years ago

  • Status changed from 3 to Closed

Also available in: Atom PDF