Project

General

Profile

Bug #671

Subtotal not correct

Added by Pascal Molecule over 8 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Target version:
Start date:
04/02/2013
Due date:
% Done:

0%

Invoice time (hours):

Description

Hi,

I've installed your ET Currency Manager. I work with Magento 1.6.1.0
I was very happy i found it, there's only 1 problem with it.
The program rounds the subtotal to 0 decimals and then it calculates along with that.
The tax gets calculated good. I look but i can't find nothing in the panel to change it..
Can you help me?

Kind regards,

Pascal

Extension: ET Currency Manager (version 1.0.3)

PrtSc 2.docx (180 KB) Pascal Molecule, 04/02/2013 02:42 PM

PrtSc 1.docx (193 KB) Pascal Molecule, 04/02/2013 02:42 PM

TAXINVOICE-Wrong.jpg View (345 KB) Pascal Molecule, 04/02/2013 02:42 PM

3. a.png View (46.2 KB) Pascal Molecule, 04/03/2013 03:33 PM

3. b.png View (45.7 KB) Pascal Molecule, 04/03/2013 03:33 PM

3. c.png View (26.1 KB) Pascal Molecule, 04/03/2013 03:33 PM

product.png View (54.1 KB) Jurij Nikolajev, 04/03/2013 10:29 PM

cart.png View (32.4 KB) Jurij Nikolajev, 04/03/2013 10:29 PM

image2.png View (75.8 KB) Pascal Molecule, 04/04/2013 01:01 PM

no_problem_invoice.png View (45.8 KB) Jurij Nikolajev, 04/04/2013 03:20 PM

History

#1 Updated by Jurij Nikolajev over 8 years ago

  • Status changed from New to In Progress
  • Assignee set to Jurij Nikolajev
  • Target version set to ver. unsorted tasks

#2 Updated by Jurij Nikolajev over 8 years ago

Please provide more information:
1. Product real price (set in admin)
2. Base currency
3. Price display settings on page System -> Configuration -> Sales -> Tax
3.1. Calculation Settings tab
3.2. Price Display Settings tab
3.3. Shopping Cart Display Settings tab
3.4. Orders, Invoices, Credit Memos Display Settings tab
4. Tax % and quantity (have you one rule or more for this product)

#3 Updated by Jurij Nikolajev over 8 years ago

And what prices you expect? (product price in cart, subtotal, grandtotal).

#4 Updated by Pascal Molecule over 8 years ago

1. 79
2. Euro
3. see attachements
4. 21% tax and no extra rules
5. it should be 65,29 + 13,71 vat = 79

#5 Updated by Jurij Nikolajev over 8 years ago

We cannot reproduce your issue on Magento 1610 with sample data and your provided Extension and Tax settings.
See attachments.

Almost every time we had requests similar to yours, it was fault of some 3rd party extensions or theme modifications, which doesn't allow our extension to work normally. Since we can't reproduce your problem on blank Magento, we're pretty sure that your case is the same. Unfortunately, solving such problems isn't part of free support.

We can dig into your website and solve the problem, but we don't know how much time and money it'll take. At least 1 hour to find source of the problem, but amount of time for solutions depends on the type of the problem. Of course, if in the end the problem will be in our extension, we will do everything for free, but again - this is highly unlikely.

If you agree, we will need the following information:
1. Link to product
2. Link to admin (and login/password)
3. Ftp or Sftp access to site code

If you provide us this data by email (NOT in this public ticket) we will try to help you.

#6 Updated by Pascal Molecule over 8 years ago

Hi Jurij,

in the frontend everthing works ok. The only thing thats wrong is in the Backend, the billing part.
There the subtotal is the rounded number 65 and then they put the right VAT 13,71 on to it..
It should calculate there with 65,29 and not 65.
The funny part is it shows 65,29 first and then the subtotal changes to 65..
see attachement image 2

#7 Updated by Jurij Nikolajev over 8 years ago

I cannot reproduce this issue on our server.
See attach.

I think there is any third party extension that does this changes. But without access to source codes and admin i cannot help you.

#8 Updated by Jurij Nikolajev about 8 years ago

  • Status changed from In Progress to Rejected

No answer

Also available in: Atom PDF