Project

General

Profile

Bug #1124

Mageworx advanced options compatibility

Added by Luca Orlandi over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
02/25/2014
Due date:
% Done:

0%

Invoice time (hours):

Description

Hello,
I'm using mageworx's advanced options extension (http://www.mageworx.com/advanced-product-options-magento-extension.html) and I cannot understand why your currency manager does not get hooked for option prices.

cm_4_decimals.png View (286 KB) Jurij Nikolajev, 03/17/2014 11:50 AM

History

#1 Updated by Jurij Nikolajev over 7 years ago

  • Assignee set to Jurij Nikolajev
  • Target version set to ver. unsorted tasks

We are unable to guess where the problem is.
To be able to find solution we need either copy of this extension, or access to your test or production server.

We can't guarantee that our extensions will work with each and every 3rd party extension. Extension conflicts and similar issues falls outside of free support borders.

You can hire our team to find and solve your issue. Hourly rate is 20 euro.
It is difficult to estimate this task. We will need about an hour to find the issue, but how much time will be needed for solutions depends on the issue complexity.

#2 Updated by Luca Orlandi over 7 years ago

I've investigated a little more and I removed the extra extension ... unfortunately the currency manager is not involved even in plain magento options pricing anyhow.

#3 Updated by Jurij Nikolajev over 7 years ago

Provide more information about your issue, if there is one.

Magento version
Extension version
Link to page with issue (and write what you expect)

#4 Updated by Luca Orlandi over 7 years ago

Sorry for the delay.
I've noticed that 4 decimals can be configured for "product prices" and is not present in "options prices".

#5 Updated by Luca Orlandi over 7 years ago

Issu title should be now "Decimals in option prices".

#6 Updated by Jurij Nikolajev over 7 years ago

Jurij Nikolajev wrote:

Provide more information about your issue, if there is one.

Magento version
Extension version
Link to page with issue (and write what you expect)

#7 Updated by Luca Orlandi over 7 years ago

I have seen your class:
https://github.com/paales/ET_CurrencyManager/blob/master/install/app/code/community/ET/CurrencyManager/Block/Adminhtml/Catalog/Product/Edit/Tab/Options/Option.php

but I think it is not called, options are fine when I override code/local/Mage/Adminhtml/Block/Catalog/Product/Edit/Tab/Options/Option.php

#8 Updated by Luca Orlandi over 7 years ago

Sorry I did not read your request:

Magento 1.8.1
ET_CurrencyManager 1.2.1

Sorry I cannot provide the link since it is on an internal (develop) machine; I expect to see 4 (as configured) decimals for Option prices.

#9 Updated by Jurij Nikolajev over 7 years ago

Need more information how to reproduce this issue.
Here is the link to clean Magento 1.8.1.0 with demo data
http://dev2.etwebsolutions.com/magento/test/1810/apparel/shirts/the-only-children-paisley-t-shirt.html

4 decimals for configurable options are there. (link with this configuration will be available 2 days)

#10 Updated by Jurij Nikolajev about 7 years ago

  • Status changed from New to Closed

no answer

Also available in: Atom PDF